EmacsでのリージョンPHP-evalを修正

以前書いたリージョンをPHP-evalするスクリプトが動かなくなってたので、修正。
EmacsでPHP-eval

リージョンの範囲指定を、"(point-min) (point-max)"で指定していた部分を、"(region-beginning) (region-end)"に修正したら動いた。Emacs22へのバージョンアップが原因?それとも、最初から間違ってた?

コマンドラインだと"php -r '...'"で実行出来るんだけど、これをEmacsから渡す方法がよく分からないので、PHPスクリプトにパイプでリージョンを渡す方法を採用。なんとなく気持ち悪いけど、動くからよし。

プロフィール

このブログ記事について

このページは、koshigoeが2006年7月31日 21:06に書いたブログ記事です。

ひとつ前のブログ記事は「MTのスタイル変えてみた」です。

次のブログ記事は「Mapaeが使えるようになった」です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。